rubyのleveldbを使うとwarningが出るようになった

  • このエントリーをはてなブックマークに追加

RubyのLevelDBのGemは有名なものが2つあります。私は前者の方をよく利用していました。

Ruby2.7で利用してみると大量のWarningが出るようになりました。キーワード引数の代わりにハッシュを渡すと出るようです。

leveldbfiddlerに依存しており、fiddlerが原因でした。

1
/var/lib/gems/2.7.0/gems/fiddler-rb-0.1.2/lib/fiddler.rb:51: warning: Using the last argument as keyword parameters is deprecated

これを対応するのもあれなので、せっかくなのでRocksDBを利用するようにしてみます。

参考